I have RAID 5 with the following specifications: 7 400gig, one 400GIG hot spare, and one 200GIG SSD for fast caching. SOLVE:
A) Total Logical volume size
B) overhead
C)number of drives that can fail without permanent data loss
D)Total number of drive space being utilized
A) 2800gigs
B) 400 gigs (one disk)
C) 1
D) 2400gigs
What is DNS best described as?
A key value data base.
HTTP is a ______ protocol, What does this mean?
stateless
It does not retain any information
What is the function of a host header?
Lets you have multiple websites on the same IP
Name 4 DNS record types and describe their function in detail. Describe a scenario where each would be necessary.
- A- record, Your IPv4 Address record. Would be used to resolve an IPv4 IP address
- c name, Your alias record, would be used when redirecting an IP to a different domain name
- MX Record, your email record, would be used when you are trying to resolve an IP for an email address
- SRV record, server record, Gives you the general location of where is server is
What is the permissions hierarchy in Windows?
Explicit Allow
Explicit Deny
Inherited Allow
Inherited Deny
No permissions set
What is the DNS zone serial number and why is it important?
A number that changes every time the zone changes so that the DNS servers know if they need to update or not.
What OSI layer does HTTP function on?
Layer 5 Session
Describe the series of events that occur when an application pool recycle takes place.
1. A new worker process is created
2. All new connections are sent to the new worker process
3. Wait for the old connects to bleed off of the old worker process
4. Kill the old worker process once all of the connections are gone
What is processor affinity?
Where applications pools can be set to run on the processor of its choice
What is rapid fail protection? And why might it be used.
Rapid fail protection is used when a worker process fails to load a specific number of times. It can take up a lot of resources and even crash the box because the fail worker processes will continue to use resources.
What setting in IIS might I change if i want to ensure that a specific group in windows can log into my web site?
Change the authentication to MS Windows, and them make sure that the user groups have the right permissions.
Name 2 ways to fix an open SMTP relay.
All only specific connections through the firewall
Make the SMTP server require some sort of authentication
What is the overhead on a RAID 0 array?
There is no overhead
My website users are complaining that everyday at 4PM they loose all their information and have to start over. What might be the cause, and how might I fix it?
The application pool is recycling every 24 hours. Change the time of the recycle to off peak hours.
What file is used to begin an iterative query on a DNS server.
root hints file
Which port is used by default to initiate the command connections in FTP?
Port 21
Which of these authentication methods is most secure?
D)
I start an FTP session wherein my client establishes the command and data connection and then sends the PORT command. Which type of FTP session is this? How can you tell?
This is not A valid command
I start an FTP session over port 21, and I am directed to a folder with my information in it. When my coworker goes to the same site they get a completely different folder. What is most likely configured on the server?
FTP user isolation
What function of an IIS application pool allows a specification of the generation of code being used by the IIS engine
.net framework
What is the Kernel32.dll?
The kernel for the 32 bit operating system
What command line tool might you use to modify disk partitions and change volume types?
diskpart
My Application code was programmed specifically for use in versions prior to IIS7. When I migrated my site from our 2k3 box to our new 2k8R2 box, i noticed that the site was running improperly, Specifically I was getting a lot of error codes, and certain pages would not even render correctly. What setting might I try to change first when trouble shooting this issue?